View Single Post
  #7  
Old 16th April 2009, 18:07
jamesls jamesls is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default

The more I play with ispconfig 3 and the more I read, the more impressed I am with this software, its a nice open framework that allows you to do almost anything you wish, the data stored in a table format make it easy to develope from a programing pespective.
Well done!!

Anyway

All the web sites have a "*" in ispconfig > sites >IP Address, I don't have the option to enter an IP.
I also had a look at my apache config files

In my /etc/apache2/sites-available/ mywebsite1.conf I have:-


..
<VirtualHost *:80>
DocumentRoot /var/www/victim6.co.co/web

ServerName victim6.co.co
ServerAdmin webmaster@victim6.co.co


## added for isp config
NameVirtualHost 192.168.100:80 192.168.0.100 is my wireless card
<VirtualHost 192.168.0.100:80>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/apache2-default/

..

Reading the apache virtual hosts docs surgest that its configured to "names".

In ispconfig I have entered the ip 10.0.0.10 of my wired nic for all the A records (I have 2 network cards)

I've just setup another web site using the ip 192... and that won't work with webmail unless I add a link to squirrelmail.

james
Reply With Quote