View Single Post
  #1  
Old 11th April 2009, 06:01
jamesls jamesls is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache not starting up after installing ispconfig3

Hi

I'm using ubuntu 8.10
I followed the perfect server for ubuntu 8.10 and it worked fine for a week
I then installed the ispconfig 3 and now apache won't start it says

[warn] namevirtualhost 192.168.0.100:8080 has no virtual hosts
[warn] namevirtualhost 192.168.0.100:* has no virtual hosts
[warn] namevirtualhost 192.168.0.100:80 has no virtual hosts

[fail]

I also think I'm missing some sub directories off /var/www/ I only have 3, webalizer, ispconfig, php-cgi-scripts
Looking at some config files for apache they mention directiories like "client" and in an error file there's another one for vlogger ... I don't appear to have them.

I installed the desktop version of ubuntu not the server version I hope that doesn't make a big difference.

I'd apreciate any help
James

below is part of my apache error log

[Fri Apr 10 19:47:29 2009] [warn] child process 14809 still did not exit, sending a SIGTERM
[Fri Apr 10 19:47:29 2009] [warn] child process 14810 still did not exit, sending a SIGTERM
[Fri Apr 10 19:47:29 2009] [warn] child process 14811 still did not exit, sending a SIGTERM
[Fri Apr 10 19:47:31 2009] [notice] caught SIGTERM, shutting down
[Fri Apr 10 21:03:18 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Apr 10 21:03:36 2009] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Fri Apr 10 21:03:36 2009] [notice] mod_python: using mutex_directory /tmp
[Fri Apr 10 21:03:36 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.1 with Suhosin-Patch mod_python/3.3.1 Python/2.5.2 mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Fri Apr 10 21:57:34 2009] [warn] child process 5839 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:34 2009] [warn] child process 5840 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:34 2009] [warn] child process 5841 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:34 2009] [warn] child process 5842 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:34 2009] [warn] child process 5843 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:36 2009] [warn] child process 5839 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:36 2009] [warn] child process 5840 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:36 2009] [warn] child process 5841 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:36 2009] [warn] child process 5842 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:36 2009] [warn] child process 5843 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:38 2009] [warn] child process 5839 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:38 2009] [warn] child process 5840 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:38 2009] [warn] child process 5841 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:38 2009] [warn] child process 5842 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:38 2009] [warn] child process 5843 still did not exit, sending a SIGTERM
[Fri Apr 10 21:57:40 2009] [error] child process 5839 still did not exit, sending a SIGKILL
[Fri Apr 10 21:57:40 2009] [error] child process 5840 still did not exit, sending a SIGKILL
[Fri Apr 10 21:57:40 2009] [error] child process 5841 still did not exit, sending a SIGKILL
[Fri Apr 10 21:57:40 2009] [error] child process 5842 still did not exit, sending a SIGKILL
[Fri Apr 10 21:57:40 2009] [error] child process 5843 still did not exit, sending a SIGKILL
[Fri Apr 10 21:57:41 2009] [notice] caught SIGTERM, shutting down
unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
Unable to open logs
unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
Unable to open logs
unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
Unable to open logs
unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
Unable to open logs
Reply With Quote
Sponsored Links