View Single Post
  #1  
Old 3rd April 2009, 00:09
andypl andypl is offline
Senior Member
 
Join Date: Mar 2006
Location: Warsaw, Poland
Posts: 100
Thanks: 1
Thanked 5 Times in 4 Posts
Default MySQL connect php-fcgi

Next problem in last release ISPConfig.
Problem is in connection to MySQL when websites have enabled php-fcgi.
When the website have enabled mod-php can normally connect to MySQL.

This is on error.log
[Thu Apr 02 22:49:58 2009] [error] [client xx.xx.xx.xx] client denied by server configuration: /var/www/php-fcgi-scripts/
[Thu Apr 02 22:49:58 2009] [error] [client xx.xx.xx.xx] client denied by server configuration: /var/www/clients/
This is config apache virtual host:

<VirtualHost xx.xx.xx.xx:80>

ServerName domain.ltd
ServerAdmin webmaster@domain.ltd
DocumentRoot /var/www/domain.ltd/web

ErrorLog /var/log/ispconfig/httpd/domain.ltd/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/domain.ltd>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<Directory /var/www/domain.ltd/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client0/web1/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>

# php as fast-cgi enabled
<Directory /var/www/domain.ltd/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>

</VirtualHost>

Last edited by andypl; 3rd April 2009 at 00:13.
Reply With Quote
Sponsored Links