View Single Post
  #1  
Old 29th March 2009, 14:56
webno webno is offline
Junior Member
 
Join Date: Sep 2006
Posts: 9
Thanks: 1
Thanked 2 Times in 1 Post
Default ISPConfig3 and the lenny php5-cli bug

Just informing all that running ISPConfig (or any other application that uses php5-cli) might cause segmentation faults.

I'm running lenny inside xen with a compiled kernel from xensource 2.6.18.8-xen.

I'm getting random segmentation faults in my /var/log/ispconfig/cron.log.

Code:
/usr/local/ispconfig/server/server.sh: line 7: 22245 Segmentation fault      /usr/bin/php -q /usr/local/ispconfig/server/server.php
According to:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=493045

there is a bug somewhere hidden in php5-cli.The bugreport suggests recompiling php5 as a temporary solution.

I'm rather worried that the ispconfig installation script or other scripts ispconfig uses, might run into a segmentation fault without the script itself failing, which in turn might lead to all kinds of strange errors later on for people installing or using ispconfig3 on lenny.

Bart.
Reply With Quote
Sponsored Links