View Single Post
  #6  
Old 22nd March 2009, 13:15
DonAteloNow DonAteloNow is offline
Junior Member
 
Join Date: Oct 2008
Location: Lithuania
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to DonAteloNow Send a message via MSN to DonAteloNow Send a message via Skype™ to DonAteloNow
Default Webinterface with Apache2 Worker + fcgid

No luck with solution below - still the same result.


+ ispconfig need its own php-fcgi-script /var/www/php-fcgi-scripts/ispconfig
+ symbolic link to /usr/local/ispconfig/interface/web in /var/www/ named ispconfig
+ in the 000-ispconfig.vhost the DocumentRoot has to be set to: /var/www/ispconfig

the mod_fastcgi.c should be changed to:

<IfModule mod_fcgid.c>
SuexecUserGroup ispconfig ispconfig
<Directory /var/www/ispconfig/>
Options Indexes FollowSymLinks MultiViews +ExecCGI
AllowOverride AuthConfig Indexes Limit Options FileInfo
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
Order allow,deny
Allow from all
</Directory>
</IfModule>

#!/bin/sh
PHPRC=/etc/php5/cgi/
export PHPRC
exec /usr/lib/cgi-bin/php
PHP_FCGI_MAX_REQUESTS=5000
export PHP_FCGI_MAX_REQUESTS
export PHP_FCGI_CHILDREN=8
export PHP_FCGI_MAX_REQUESTS=500
Reply With Quote