View Single Post
  #3  
Old 21st March 2009, 03:47
newbie2008 newbie2008 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 14
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
This is a problem with your settings.

1) If you uncheck the php option in the site settings then PHP is disabled and you see the sourcecode. hats the intended behaviour of disabling PHP Enable it and it in the site settings and it should work properly. You can not enable php globally, take a look at the perfect setup guide and configure your server properly as described there.
Sorry that I have typo, actually I have disabled PHP Globally before. Here is my /etc/httpd/conf.d/php.conf as

# AddType application/x-httpd-php .php
# AddType application/x-httpd-php-source .phps

so, is it inevitable to show the php source code or I must remove any .php programs under /web ? This might be inconvenience for temporary disable php function per virtual website!
Reply With Quote