View Single Post
  #13  
Old 4th March 2006, 19:37
Kamran Shah Kamran Shah is offline
Junior Member
 
Join Date: Oct 2005
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default segmentation fault or whatever but still not working

Hi,

It took me a while in investigating again and coming back to forum as I broke all of my system in debugging.

I initially had a RAID mirroring installed on Redhat FC4 so to debut I ran memtest on memory which passed without any errors. Secondly I took primary hard disk and performed full format using DOS disk which came back without any errors and no bad sectors at all. I tried to establish RAID again but secondary disk wouldn't boot up so I literally *ed up my system. I had a backup of system so performed format on secondary disk again and again no errors at all.

Now I decided to re-install system, one of the newer disk is now main disk, older disk is spare where I am keeing a scheduled backup with rdiff-backup instead of mirroring.

Worked fine for couple of weeks, been playing with rdiff bakup and found quite handy & useful.

Two days back I got a cronwatch error again I think this is where my previous problems started from.

Cron started producing following error.
Use of uninitialized value in numeric le (<=) at /etc/cron.daily/0logwatch line 683.

I can replicate this error by executing /etc/cron.daily/0logwatch but it produces LogWatch output perfectly which I get in root email. I suspect yum installed following updates around the first error.
kernel.i686 2.6.15-1.1833_FC4 & kernel-devel.i686 2.6.15-1.1833_FC4
and dhclient.i386 10:3.0.2-34.FC4 xterm.i386 208-2.FC4 a day before that.

Today when I tried to stop firewall, looked working but again I thought of restarting couple of services as a test and got stuck there. Services Restart command doesn't work again.

I have now uninstalled following and still cannot restart services.
rpm -e kernel.i686 2.6.15-1.1833_FC4 kernel-devel.i686 2.6.15-1.1833_FC4

In my today's investigation I also get segmentation fault when I execute following.
rm /root/ispconfig/.ispconfig_lock -rf
/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

As I have yum scheduled to update every night, I suppose this is something done by updates which ruined ispconfig or rather the system itself.

I do not believe there are any hardware errors in disk or memory as I have performed full tests earlier and do not see any symptoms at all. Not getting any luck with ISPConfig, not sure if it is worth trying webmin.

Any suggestions please?
Reply With Quote