View Single Post
  #1  
Old 6th March 2009, 03:35
savetz savetz is offline
Junior Member
 
Join Date: Mar 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Set Up Postfix DKIM With dkim-milter: glibc error

Hi. I'm trying to use the document "Set Up Postfix DKIM With dkim-milter" (http://www.howtoforge.org/postfix-dk...lter-centos5.1) and things have been going well, until:

# /sbin/service dkim-milter start
Starting DKIM milter (dkim-filter #0): /usr/sbin/dkim-filter: error while loading shared libraries: requires glibc 2.5 or later dynamic linker
[FAILED]

I asked my webhost about upgrading and they said:

"Upgrading glibc is a highly bad idea. More often than not, upgrading glibc usually breaks every thing installed on the system.

If you are requiring a later version of glibc you will need to rekick to redhat 5.

The glibc that is updated via up2date has been certified is an increment release which will not break anything."

(Looks like I have glibc 2.3.4.)

Upgrading to redhat 5 like a lot of work just to get DKIM working. Is there a way to get dkim-milter to play nice with my older version of glibc?

Thanks for any advice,
Kevin
Reply With Quote
Sponsored Links