View Single Post
  #2  
Old 28th February 2006, 10:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Quote:
Originally Posted by brainz
Hi all

Im Sorry to butt in like this i have a quick question if i may....

I have setup FC4 server running ISPconfig and i have follow the tuts probably about 4 to 5 times now as i built and rebuilt the server from scratch over and over again many wouldnt i considered a good learning curve and it was fun...

Anyway to my question....

I noticed that all is well on internal side of my network and all works nice...
But when i goto work and try to access the server no go blank page server timed out type messages. Server is behind a NAT(home variety router) do i have to make sure that all these port are forwarded to the server ???
No. Only the ports where you want to access the server from the outside. Eg.g if you want to access the webserver, port 80 must be forwarded. For the ISPConfig interface, port 81. If you want to access all services from outside, forward all ports listed below except port 10000.

Quote:
Name Port Type Active
FTP 21 tcp yes
SSH 22 tcp yes
SMTP 25 tcp yes
DNS 53 tcp yes
DNS 53 udp yes
WWW 80 tcp yes
ISPConfig 81 tcp yes
POP3 110 tcp yes
SSL (www)443 tcp yes
Webmin 10000 tcp yes

This is take directly from the iptables firewall settings in ISPconfig admin panel

What i dont understand is this on my home variety router these port are forwarded to the server

Virtual Server FTP 192.168.*.*TCP 21/21 always
Virtual Server SSH 192.168.*.* TCP 22/22 always
Virtual Server HTTP 192.168.*.* TCP 80/80 always
Virtual Server HTTPS 192.168.*.* TCP 443/443 always
Virtual Server DNS 192.168.*.* UDP 53/53 always
Virtual Server SMTP 192.168.*.* TCP 25/25 always
Virtual Server POP3 192.168.*.* TCP 110/110 always
Virtual Server HTTP port 81 192.168.*.* TCP 81/81 always

The 192.168.*.* is primary server ip.

I tried this and it doesnt seem to give me access from outside it doesnt seem to work there is also a virtual server ip do i need to port forward all ports in the list above for the virtual ip ???
No, just use your main server IP.

Quote:
I also get a message when i reboot the server about the primary internal ip address not having a virtualhost

something like this

[warn] NameVirtualHost 192.168.*.*:80 does not have a virtualhost

i did read about this and you guys having very good tutorials and stuff to read on this site and it has to do with apache or php filters and this was being addressed in the next version of ISPconfig as i sore in the dev forum.

but i was wondering if this had something to do with not being able to access the server from the outside.
Have you created the website in ISPConfig on this IP or on the second (virtual) IP?

Quote:
I also did read that for SSL site you need a ip per site so as admin i created a client then a web for this client and activated the SSL and SSI but from my limited knowledge in order to have multible webs on the 1 ip do i have to deactive SSL and SSI for the clients web ???
You can activate SSL only on one website per IP, you will get an error from ISPConfig i you try to activate it on another website.

Quote:
Just one other question i noticed with ProFtp when i try and access it using smartftp on another computer within the network some files are uploaded and some arnt uploaded and the ones that dont make smartftp hang and i need to restart smartftp and i have tried this with pasv auto and non pasv 10101 and all the combos it still hangs on certain files and not others.

One thing i did notice is on this computer within my network as soon as i turn the firewall off on the computer all the files transfer but there is a lag during each file and i think there is a error message say something like this...

550 file.ext: No such file or directory
Did you get any errors in your syslog or xferlog?

Quote:
Anyway i have said my piece this as much as i could collect in one go....

I would very much apreciate anyones contribution to my questions here
Other then that you know what all the stuff on the site and the forums are A1 or A+ which ever you prefer...

Also i did a httpd and the output is this....

[root@xxx ~]# httpd
[Tue Feb 28 09:03:17 2006] [warn] NameVirtualHost 192.168.*.*:80 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
[root@xxx ~]#

just wondering what this means ???
This means that there is already a webserver running. I guess you want to test your server with:

httpd -t

which tests the server configuration.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote