View Single Post
  #10  
Old 13th February 2009, 08:58
Allen15 Allen15 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 29
Thanks: 4
Thanked 0 Times in 0 Posts
Default

I would have to guess that you either are missing some installation package or had an error during the perfect-server-setup installation that you missed while installing something, OR you have the wrong version of something installed.

I know this all sounds like a royal PITA, but did you try re-installing all of the packages listed in the perfect server setup guide, and did you do a copy and paste of ALL of those lines directly from the web page to a remote shell?

When I went back through determined to make this work or catch the error in the installation, I did each step, and then tried to look for ways to verify that each step actually completed properly. The first step of installing OpenSSH server is pretty easy to verify, because you can't get a remote PuTTY session to work if that step wasn't properly done at the console, but each step thereafter gives an opportunity to test to see if it worked or will be what is tripping you up.

I don't know if there is an official way to verify step 9, but what I did was to type gibberish at the prompt, and upon pressing enter, I got a response from the command shell that what junk I'd typed was an unknown command, and looked something like this: "bash: tgarihgo: unreconized command or filename."

I don't know if that is worth anything, but nearly every other step produced results that were readily verified. Anything you install with apt-get install will either return a result that it is already installed, or go through the process of installing, sometimes prompting you to approve the additional hard drive space/usage.

There was also a thread I found somewhere in this forum where the discussion suggested that some of the packages had changed contents over the life of the tutorial, and didn't (no longer?) automatically install all of the needed libraries and/or modules, but I didn't mark it, and don't remember it. You could have some modules or libraries that may have been removed because they were thought to be orphaned but turned out to be needed later on. Try re-installing EVERYTHING that you installed with apt-get and watch the outputs to see if anything actually installs, and then do the triple dump of dropping/deleting the mysql database, deleting the /root/ispconfig directory recursively, and also the install directory too. Re-extract ISPConfig from the tar.gz file, and try it again?

Good luck.
Reply With Quote