View Single Post
  #1  
Old 12th February 2009, 05:38
Paladinemishakal Paladinemishakal is offline
Junior Member
 
Join Date: Jan 2008
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy Awstats config problem

Hi All,

I am having some problem with configuring awstats on Debian sarge and Apache2. I have multiple vhosts configured in Apache2 and I have also install awstats to enable log statistics for each site. Due to a request by a user, I have to enable basic authentication for one of the awstats config.

Location of awstats.pl : /var/www/awstats/cgi-bin
Location of awstats apache config : /etc/apache2/sites-enabled/awstats

I put this config into the apache config for awstats:
ScriptAlias /cgi-bin/ /srv/www/awstats/cgi-bin/
<Directory "/srv/www/awstats/cgi-bin">
#AllowOverride None
AllowOverride AuthConfig
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

I created .htaccess and .htpasswd in /var/www/awstats/cgi-bin
--------Content of .htpasswd----------------------
AuthUserFile /var/www/awstats/cgi-bin/.htpasswd
AuthGroupFile /dev/null
AuthName "XXX Awstats"
AuthType Basic
#require user stats
Require valid-user
---------------------------------------------------

Site A: http://awstats.xxx.com/awstats/awsta...config=abc.com
Site B: http://awstats.xxx.com/awstats/awsta...config=def.com

I have created a separate data directory for each awstats config:
1. DirData="/var/www/awstats/cgi-bin/abc.com"
2. DirData="/var/www/awstats/cgi-bin/def.com"

When I access my awstats site for each config, I get a password prompt. What I want to do is to just setup Site A with a password prompt and not Site B. How can i do this?

Thanks & Regards.
Reply With Quote
Sponsored Links