View Single Post
  #13  
Old 4th February 2009, 02:24
AceFrahm AceFrahm is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Thanks: 3
Thanked 0 Times in 0 Posts
Question

I followed Inco's instruction, but I don't really know what it does, I was just hoping for something simple that would work.
Quote:
Originally Posted by Inco View Post
problem in master.cf in postfix, with arguments who send pipe to maildrop and .mailfilter don't know this argument.
known torouble as "user unknown. Command output: /usr/local/bin/maildrop: Invalid user specified."
I use next configuration master.cf


maildrop unix - n n - - pipe
flags=R user=vmail argv=/usr/bin/maildrop -dvmail ${extension} ${recipient} ${user} ${domain} ${sender}

work fine. ubuntu 8.10
I tried Inco's solution with jpb77's extra space added, on a fresh complete reinstallation.
Quote:
Originally Posted by jpb77 View Post
Same problem here with Ubuntu 8.10.

Now it's working with Inco's solution, but you must put a space between "-d" and "vmail":

flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${domain} ${sender}

Thanks Inco.
It did not work for me. I get the same error.

I also get the same result as gemini:
Quote:
Originally Posted by gemini View Post
maildrop -d my_email@my_domain.com
shows "Invalid user specified"
while I'm sure there is such user within mysql DB of IspConfig
Does the maildrop use some cache or something or should it use straight from mysql? Because I don't see any queries to DB.
But I can see my e-mail user in the MySQL ispconfigdb mail_user table!!!???


maildrop -d ___ace___.___frahm___@__acefrahm___.com [without the underscores]

produces the same "Invalid user specified" message for me that gemini got.

-----------------------------------------------
I would like to use ISPConfig as a no-brainer IMAP mailbox auto-config, but I'm willing to learn how to make a mail-server run from scratch if I must.

till: when you said:
Quote:
Originally Posted by till View Post
Your system seems to work properly. You will just have to change the mailscan option for the email account and domain to not rejecet bad headers.
What did you mean exactly?
This user already has no spamfilter applied, and no other rules of any kind applied.
Exactly how do I tell ISPConfig to accept bad headers, and if I do, aren't I defeating spam filtering and Clam Antivirus?
Reply With Quote