View Single Post
  #35  
Old 24th January 2009, 19:42
mifa mifa is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi there, I have been following the SpamSnake setup and most things are running great, thanks for the tutorial!

I have a similar problem to what David had, it appears that everything is running, mailscanner is seeing mail and it's getting scanned, but I'm not seeing any external mail in MailWatch. Here's what i've done to get here and my troubleshooting:

I followed the tut to 9.15, rebooted and everything seemed to be running. I moved on and made it down to step 9.26, I tested Mailwatch and noticed I had not received any more mail in the previous 2 hours. Checked mail.log and everything looks fine

Jan 24 12:21:58 mw-254 postfix/smtpd[23671]: lost connection after CONNECT from unknown[190.3.215.219]
Jan 24 12:21:58 mw-254 postfix/smtpd[23671]: disconnect from unknown[190.3.215.219]
Jan 24 12:21:59 mw-254 postfix/smtpd[22543]: connect from pool-71-127-234-86.nwrknj.east.verizon.net[71.127.234.86]
Jan 24 12:21:59 mw-254 postfix/smtpd[22543]: NOQUEUE: reject: RCPT from pool-71-127-234-86.nwrknj.east.verizon.net[71.127.234.86]: 554 5.7.1 <addr@example.com>: Relay access denied; from=<sleekest0166@nailsbyliz.com> to=<addr@example.com> proto=ESMTP helo=<pool-71-127-234-86.nwrknj.east.verizon.net>


Checked for mailscanner errors....and the following lines usually repeat themselves every 10 minutes <- Is that a problem?

Jan 24 12:13:25 mw-254 MailScanner: MailScanner setting GID to www-data (33)
Jan 24 12:13:25 mw-254 MailScanner: MailScanner setting UID to postfix (108)
Jan 24 12:13:27 mw-254 MailScanner[23759]: MailScanner E-Mail Virus Scanner version 4.71.10 starting...
Jan 24 12:13:28 mw-254 MailScanner[23759]: Read 830 hostnames from the phishing whitelist
Jan 24 12:13:28 mw-254 MailScanner[23759]: Read 5298 hostnames from the phishing blacklist
Jan 24 12:13:28 mw-254 MailScanner[23759]: Config: calling custom init function SQLBlacklist
Jan 24 12:13:28 mw-254 MailScanner[23759]: Starting up SQL Blacklist
Jan 24 12:13:29 mw-254 MailScanner[23759]: Read 0 blacklist entries
Jan 24 12:13:29 mw-254 MailScanner[23759]: Config: calling custom init function MailWatchLogging
Jan 24 12:13:29 mw-254 MailScanner[23759]: Started SQL Logging child
Jan 24 12:13:30 mw-254 MailScanner[23759]: Config: calling custom init function SQLWhitelist
Jan 24 12:13:30 mw-254 MailScanner[23759]: Starting up SQL Whitelist
Jan 24 12:13:30 mw-254 MailScanner[23759]: Read 0 whitelist entries
Jan 24 12:13:30 mw-254 MailScanner[23759]: SpamAssassin temporary working directory is /var/spool/MailScanner/incoming/SpamAssassin-Temp
Jan 24 12:13:31 mw-254 MailScanner[23759]: Using SpamAssassin results cache
Jan 24 12:13:31 mw-254 MailScanner[23759]: Connected to SpamAssassin cache database
Jan 24 12:13:31 mw-254 MailScanner[23759]: Enabling SpamAssassin auto-whitelist functionality...
Jan 24 12:13:34 mw-254 MailScanner[23759]: Using locktype = flock


....everything looks good to me. So I figured I had messed something up between 9.15 and 9.26. After a while of troubleshooting I got frustrated and completely removed mailscanner from the system and started again from Step 8. Everything looked good all the way until I got to 9.15, restarted the system and have the same problem: mailscanner looks like it's doing it's job but the bayes database isn't being updated and I'm not seeing external mail flow through (I am seeing internal mail).

I had the same HUNK error that David posted, replaced my postfix.inc and functions.php with those provided by Rocky, dropped all the tables in my db. Still no love.

I figured this could be a permissions issue so looked at my lint test, it completes successfully, no warnings or errors. Here's the bayes part of my lint test


[23127] dbg: bayes: using username: root
[23127] dbg: bayes: database connection established
[23127] dbg: bayes: found bayes db version 3
[23127] dbg: bayes: Using userid: 2
[23127] dbg: bayes: not available for scanning, only 0 spam(s) in bayes DB < 200
[23127] dbg: config: score set 0 chosen.
[23127] dbg: message: main message type: text/plain
[23127] dbg: message: ---- MIME PARSER START ----
[23127] dbg: message: parsing normal part
[23127] dbg: message: ---- MIME PARSER END ----
[23127] dbg: plugin: Mail::SpamAssassin::Plugin:NSEval=HASH(0x989729c ) implements 'check_start', priority 0
[23127] dbg: bayes: database connection established
[23127] dbg: bayes: found bayes db version 3
[23127] dbg: bayes: Using userid: 2
[23127] dbg: bayes: not available for scanning, only 0 spam(s) in bayes DB < 200
[23127] dbg: plugin: Mail::SpamAssassin::Plugin::Check=HASH(0x95c7658) implements 'check_main', priority 0
[23127] dbg: conf: trusted_networks are not configured; it is recommended that you configure trusted_networks manually
[23127] dbg: metadata: X-Spam-Relays-Trusted:
[23127] dbg: metadata: X-Spam-Relays-Untrusted:
[23127] dbg: metadata: X-Spam-Relays-Internal:
[23127] dbg: metadata: X-Spam-Relays-External:
[23127] dbg: message: no encoding detected
[23127] dbg: plugin: Mail::SpamAssassin::Plugin::URIDNSBL=HASH(0x94bfed c) implements 'parsed_metadata', priority 0


Any help would be greatly appreciated

/mike
Reply With Quote