View Single Post
  #3  
Old 24th January 2009, 14:33
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 420
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

there is not -a option.


Sorry for bothering, i have found the solution here: http://www.dmo.ca/blog/20081009143754


So all we need to do is:

Stop bind:

Code:
/etc/init.d/bind9 stop
edit (create)
nano /etc/rsyslog.d/bind-chroot.conf and add line
Code:
$AddUnixListenSocket /var/lib/named/dev/log
check the you have added following in bind conf as described in etch perfect setup
nano /etc/default/bind
Code:
OPTIONS="-u bind -t /var/lib/named"
restart rsyslog
/etc/init.d/rsyslog restart

make sure it creates /dev/log in the chroot:
Code:
ls -al /var/lib/named/dev/log
srw-rw-rw- 1 root root 0 2009-01-24 13:45 /var/lib/named/dev/log
start bind
Code:
/etc/init.d/bind9 start
and make sure in works
Code:
ps ax | grep [n]amed
28512 ?        Ssl    0:00 /usr/sbin/named -u bind -t /var/lib/named

Last edited by radim_h; 19th March 2009 at 20:44.
Reply With Quote