View Single Post
  #3  
Old 13th January 2009, 18:50
mikey169 mikey169 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i'm in trouble with similar problems...

first.. how did you manage to get the "ssl_error_rx_record_too_long" error?
to get there.. i needed to add a "Listen 443" in ports.conf and then restart the apache2-service..

why does ispconfig3 this not automatically?

now, i finally got a site working by editing the sites-enabled/000-default
i changed line 1 and 2

old:
Code:
NameVirtualHost *
<VirtualHost *>
new:
Code:
NameVirtualHost localhost
<VirtualHost localhost>
then some error-messages at apache2-start dissappeared and the https://domain.tld worked well..

but i am still asking myself why these two changes in config-files cannot be done by ispconfig3?

also i would like to know how to get the ispconfig3-panel working under https...

*EDIT*

now i got ispconfig3-panel over https working!

from every site i removed ssl-options and then i added the following lines to /etc/apache2/sites-available/ispconfig.vhost

Code:
<IfModule mod_ssl.c>
###########################################################
# SSL Vhost
###########################################################
Listen 443
<VirtualHost *:443>
    DocumentRoot /usr/local/ispconfig/interface/web

    SSLEngine on
    SSLCertificateFile /path/to/certificate/theCertFile.crt
    SSLCertificateKeyFile /path/to/key/theKeyFile.key

</VirtualHost>
</IfModule>
it works, but it seems to me that it is not a very clean solution..

Last edited by mikey169; 14th January 2009 at 12:42.
Reply With Quote