View Single Post
  #1  
Old 13th January 2009, 10:37
novaflash novaflash is offline
Junior Member
 
Join Date: Jan 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy SSL on ISPconfig3 not working

Well, at least not for me.

I am running Debian Etch 4.0 and I installed ISPconfig3 but for some reason when I access https://192.168.47.104:8080/ I get the error message: (in firefox)

SSL received a record that exceeded the maximum permissible length.
(Error code: ssl_error_rx_record_too_long)

I tried googling around a bit for this error but it seems it's somewhere in the Apache2 configuration. I looked around in the vhosts files and couldn't find a mention of an SSL module anywhere. Only in mods-enabled I found a mention of ssl.conf and ssl.load.

Any help on how to proceed from here? I figure messing with the apache2 configuration files won't help me since they'll most likely be rewritten by ISPconfig 3 the moment I make a change using the panel. (I can access it via http://192.168.47.104:8080, without SSL)

I also tried adding a new site, added the domainname to my local hosts file so I could access it, and it works. But again, when I check the box for SSL support and generate a certificate, it won't work and give me the same error as mentioned above.
Reply With Quote
Sponsored Links