View Single Post
  #7  
Old 9th January 2009, 11:19
usul usul is offline
Junior Member
 
Join Date: Jan 2009
Posts: 8
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I do not know, probably is part of the script called previously joomla_hisa_it_1_1.php type or magenta-check.php.

Repeated now required info.php me the following error

Quote:
[Fri Jan 09 09:37:06 2009] [error] [client 79.15.213.90] SecurityException in Application.cpp:511: Unknown Interpreter: php
[Fri Jan 09 09:37:06 2009] [error] [client 79.15.213.90] Premature end of script headers: info.php
[Fri Jan 09 09:37:10 2009] [error] [client 79.15.213.90] File does not exist: /var/www/web14/web/favicon.ico
[Fri Jan 09 09:53:19 2009] [error] [client 79.15.213.90] SecurityException in Application.cpp:511: Unknown Interpreter: php
[Fri Jan 09 09:53:19 2009] [error] [client 79.15.213.90] Premature end of script headers: info.php

By reading some documents, I have the impression that there is a configuration problem on the site www.suphp.org cautions that we need to change the configuration has changed because of the way of writing code, such as the "" but I did not understand much, even making the changes required that highlights in green, nothing has changed.

I attach the configuration file

Quote:
[global]
;Path to logfile
logfile=/var/log/suphp.log

;Loglevel
loglevel=warninfo

;User Apache is running as
webserver_user=apache

;Path all scripts have to be in
docroot=/

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=true
allow_file_others_writeable=false
allow_directory_group_writeable=true
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=00220077

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100

[handlers]
;Handler for php-scripts
x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper should be / usr / bin / php-cgi?
also looking at php-wrapper footnote 1, I can not find the reference to php-cgi it is necessary to run suPHP.


;Handler for CGI-scripts
x-suphp-cgi=execute:!self

footnote 1
Quote:
#!/bin/sh
PATH="/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec"

BASEDIR=`dirname ${DOCUMENT_ROOT}`
TMPDIR=${BASEDIR}/phptmp
SESSDIR=${TMPDIR}

if [ X"${php_safe_mode}" != X"On" ]; then
SAFE_MODE="Off"
else
SAFE_MODE="On"
fi

exec php-cgi -d open_basedir=${BASEDIR} -d upload_tmp_dir=${TMPDIR} -d session.save_path=${SESSDIR} -d safe_mode=${SAFE_MODE}
I wonder should I disable suEXEC? and how?

Thanks for your attention
Reply With Quote