View Single Post
  #1  
Old 6th January 2009, 14:25
usul usul is offline
Junior Member
 
Join Date: Jan 2009
Posts: 8
Thanks: 0
Thanked 2 Times in 2 Posts
Default Problems installing suPHP 0.7.0 on centos 5.2 ISPconfig

Hello World

I apologize for my Google English!

I'm trying to install suPHP for the management of permits for Joomla and magenta.

I installed on Server:
Centos 5.2 updated with php 5.2.8, Apache 2.0 API Handler
ISPConfig 2.2.29

I tried to run your post:

http://www.howtoforge.com/install-su...2.20-and-above

http://www.howtoforge.org/suphp_fedo...with_ispconfig


with both when I run the command:
Quote:
./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=paranoid --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes
After a series of controls the operation concludes with the following error

Quote:
checking for string.h... (cached) yes
checking for unistd.h... (cached) yes
checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
build directory, or an apr-config file.
to control the path of APR I launched:
Quote:
> locate apr-
/usr/lib/libapr-1.so.0
/usr/lib/libapr-1.so.0.2.7
/usr/share/doc/apr-1.2.7
/usr/share/doc/apr-util-1.2.7
/usr/share/doc/apr-1.2.7/CHANGES
/usr/share/doc/apr-1.2.7/LICENSE
/usr/share/doc/apr-1.2.7/NOTICE
/usr/share/doc/apr-util-1.2.7/CHANGES
/usr/share/doc/apr-util-1.2.7/LICENSE
/usr/share/doc/apr-util-1.2.7/NOTICE
after checking on http://man.root.cz/1/apr-1-config/ I think I have understood that there is no parameter, but what?


Additional questions, I will have to install APC cache, get the best magenta and beyond, given me advice on this? perhaps some links.

They told me that it would be better suexec + fast-cgi php-cgi instead of suPHP, but with APC suexec works?


Thank you in advance.


Problem-dependent configuration suphp.conf, see last post.

Last edited by usul; 9th January 2009 at 11:36.
Reply With Quote
Sponsored Links