View Single Post
  #7  
Old 8th December 2008, 13:44
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Unhappy almost the same problem

Hi,

This is my sources list:
Code:
deb http://ftp.de.debian.org/debian/ etch main contrib non-free
#deb http://ftp.de.debian.org/debian experimental main
deb-src http://ftp.de.debian.org/debian/ etch main contrib non-free

#deb http://security.debian.org/ etch updates main

#deb http://www.backports.org/debian stable ucf
#deb http://people.debian.org/~dexter php5 woody
#deb-src http://people.debian.org/~dexter php5 woody


# ### added for support of php5
# ## France
#deb http://packages.dotdeb.org stable all
#deb-src http://packages.dotdeb.org stable all
I have recently removed (commented out) the dotdeb sources. When I do the line:
Code:
apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
I get:
Code:
Reading package lists... Done
Building dependency tree... Done
libapache2-mod-php5 is already the newest version.
php5 is already the newest version.
php5-common is already the newest version.
php5-curl is already the newest version.
php5-dev is already the newest version.
php5-gd is already the newest version.
php5-imap is already the newest version.
php5-mhash is already the newest version.
php5-mysql is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-mcrypt: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-pspell: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-recode: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-snmp: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-sqlite: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-tidy: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-xmlrpc: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
  php5-xsl: Depends: php5-common (= 5.2.0-8+etch13) but 5.2.6-0.dotdeb.1 is to be installed
E: Broken packages
However, when I uncomment the dotdeb lines in sources.list, it tells me this:
Code:
Reading package lists... Done
Building dependency tree... Done
The following packages have been kept back:
  libkrb5-17-heimdal libmysqlclient15-dev openssh-client openssh-server
The following packages will be upgraded:
  libapache-mod-php5 libapache2-mod-php5 mysql-common php5 php5-cli php5-common php5-curl php5-dev php5-gd php5-imap php5-ldap
  php5-mhash php5-mysql php5-odbc
14 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 9141kB of archives.
After unpacking 160kB of additional disk space will be used.
Do you want to continue [Y/n]? 
WARNING: The following packages cannot be authenticated!
  php5-cli libapache2-mod-php5 php5-mysql php5-mhash php5-imap php5-ldap php5-curl php5-gd php5-odbc libapache-mod-php5
  php5-common mysql-common php5 php5-dev
Install these packages without verification [y/N]?
It's a bit of a dilemma because I tried downgrading the php version before but failed. Since I have a cron job, which runs apt-get update every week and apt-get -S uprade (cant remember the exact parameter for simulate) and emails me the output, so that i can upgrade if necessary, it would be nice, if I wouldn always get an email saying, that apt-get failed etc. I would like to only bother logging in when I know it is necessary to do an upgrade.

Please help. I've been stuck on this for ages now.
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote