View Single Post
  #1  
Old 30th November 2008, 21:02
mrcs9 mrcs9 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Chillispot login failed - Freeradius sql error?

I found the tutorial "How to setup a Wi-Fi Hotspot" so interesting that i bought a WRT54GL just for the sake of it! It sounded that interesting. Thank you sean at Swarmhotspots!

It didnt stop there either, because i also got myself a server, which is now running debian with freeradius v2 and a sql db, which in turn helps chillispot which runs on my WRT54GL.

I have set up everything, and all seems to work fine, except a huge detail - i cant log in! I have created tons of tickets in phpmyprepaid, and i can see them finding their place in the radcheck-table, and i have cross-checked all configfiles so i know the username/password to the database is correct, but it seems that freeradius doesnt check the sql db for the credentials, but only checks with other realms!

I also think i should mention that i ran "apt-get install freeradius-mysql", since i only got tons of errors when trying to compile it myself, even after installing gcc, g++ and such.

I have attached some info from "freeradius -X" below. Hope i can get some help here! I would be very happy to get some

Code:
Listening on authentication *:1812
Listening on accounting *:1813
Ready to process requests.
rad_recv: Access-Request packet from host 192.168.10.1:2057, id=0, length=203
	User-Name = "rotif"
	User-Password = "hjd"
	NAS-IP-Address = 0.0.0.0
	Service-Type = Login-User
	Framed-IP-Address = 192.168.182.3
	Calling-Station-Id = "00-1B-63-CB-41-D3"
	Called-Station-Id = "00-22-6B-4D-62-E4"
	NAS-Identifier = "192.168.10.3"
	Acct-Session-Id = "4932ee9400000000"
	NAS-Port-Type = Wireless-802.11
	NAS-Port = 0
	Message-Authenticator = 0xa00daf4e74abdb3de0d79e97c0cc97d9
	WISPr-Logoff-URL = "http://192.168.182.1:3990/logoff"
  Processing the authorize section of radiusd.conf
modcall: entering group authorize for request 0
  modcall[authorize]: module "preprocess" returns ok for request 0
  modcall[authorize]: module "chap" returns noop for request 0
  modcall[authorize]: module "mschap" returns noop for request 0
    rlm_realm: No '@' in User-Name = "rotif", looking up realm NULL
    rlm_realm: No such realm "NULL"
  modcall[authorize]: module "suffix" returns noop for request 0
  rlm_eap: No EAP-Message, not doing EAP
  modcall[authorize]: module "eap" returns noop for request 0
    users: Matched entry DEFAULT at line 152
  modcall[authorize]: module "files" returns ok for request 0
modcall: leaving group authorize (returns ok) for request 0
  rad_check_password:  Found Auth-Type System
auth: type "System"
  Processing the authenticate section of radiusd.conf
modcall: entering group authenticate for request 0
  modcall[authenticate]: module "unix" returns notfound for request 0
modcall: leaving group authenticate (returns notfound) for request 0
auth: Failed to validate the user.
Delaying request 0 for 1 seconds
Finished request 0
Going to the next request
--- Walking the entire request list ---
Waking up in 1 seconds...
--- Walking the entire request list ---
Waking up in 1 seconds...
--- Walking the entire request list ---
Sending Access-Reject of id 0 to 192.168.10.1 port 2057
Waking up in 4 seconds...
--- Walking the entire request list ---
Cleaning up request 0 ID 0 with timestamp 48308923
Nothing to do.  Sleeping until we see a request.
Reply With Quote
Sponsored Links