View Single Post
  #7  
Old 30th November 2008, 04:34
PermaNoob PermaNoob is offline
Senior Member
 
Join Date: Jan 2007
Posts: 194
Thanks: 12
Thanked 5 Times in 5 Posts
Default

Don't give up--router configuration is harder than server configuration ;-)

Apache sends the http requests to the right directory, and ISPConfig instructs apache for you when you setup the hosting for a domain.

Your only problem is getting the http requests passed through your router.

192.168.1.200 is only an ip for a machine within your network--it's meaningless to the outside world. Go to http://whatismyip.com to see what your ip is to the internet. That's the ip you need to put in your domain settings at the registrar (assuming you're using their dns.)

You need to tell your router to pass thru those requests for your real ip to the ip for a local machine like 192.168.1.200.

Try googling setup router for home web server
http://www.google.dk/search?hl=da&q=...%B8gning&meta=

And if you're using the dns provided by your domain registrar, you don't need to run dns on your computer, and you don't need to have ISPconfig add a dns entry when you setup a new site.

It's better to use the dns at your domain registrar imho, then if your server goes down, you can have your site back up at another ip in a few minutes compared to hours or even days if you have to change name servers in the domain settings.

Btw, that "shared ip" message just means that the domain is not in apache--when you add it with ispconfig, it will go to the right directory instead--that message has nothing to do with local dns entries.

Last edited by PermaNoob; 30th November 2008 at 04:50. Reason: add something
Reply With Quote