View Single Post
  #1  
Old 17th February 2006, 01:43
Jcorrea920 Jcorrea920 is offline
Member
 
Join Date: Feb 2006
Posts: 82
Thanks: 4
Thanked 1 Time in 1 Post
Exclamation Trouble with Mail Server

I am running Fedora Core 4 Perfect setup since last year.
By default ISPConfig uses Mbox instead of Maildir/ to hold emails. I changed it to Maildir/ so that our email clients could use it better without taking up too much space on server.
Some time on Friday Feb 11 the mail stopped working nobody could receive email from outside our local network(outside world) but smtpd still worked fine sending mail out. So since I haven't updated the software in months I ran an apt-get-install updates, but still no pop mail service. Then I ran
up2date -u and boy did it download and install a lot of updates, but still no dice.
So I discovered that it must be ipop3d that is not working properly since the error message in /var/logs/mail are Error 554 relay-access denied ipop3d[15485] Mailbox Vulnerable /var/spool/mail must have 1777 protection.

Before debugging I backed up the ISPConfig Database and All WebSites on the Server.

Then I discovered that all the Maildir/ directories were somehow converted to Mbox files. I tinkered around with Postfix, but according to the main.cf file I am set up to have Maildir/ but actually don't. Could it be my CyrusIMAP that has gone rogue? If anyone can help me get my mail server back on line and back to the Maildir/ directories, I would greatly appreciate it.
Reply With Quote
Sponsored Links