View Single Post
  #1  
Old 15th November 2008, 04:16
banzaiwebstudio.com banzaiwebstudio.com is offline
Member
 
Join Date: Aug 2008
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation ISPconfig no longer works!!!

I had set it up and was working fine.

My server (without ISPconfig) is www.banzaiwebstudio.com

I also had a testing web site which was www.banzaiwebhosting.com

Both was working fine for over 5 days.

However today something has happened and the ISPconfig just stopped working.

When i access my server on www.banzaiwebstudio.com it appears the "Shared IP page". If I access the www.banzaiwebhosting.com, it also display the "Shared IP page".

my ifconfig file is:

Quote:
eth0 Link encap:Ethernet HWaddr 00:1a:4d:4c:7a:cb
inet addr:192.168.0.7 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21a:4dff:fe4c:7acb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:45381 errors:0 dropped:0 overruns:0 frame:0
TX packets:48883 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8355905 (8.3 MB) TX bytes:21743413 (21.7 MB)
Interrupt:219 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:286046 errors:0 dropped:0 overruns:0 frame:0
TX packets:286046 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:14767313 (14.7 MB) TX bytes:14767313 (14.7 MB)

My Vhosts_ispconfig.conf:
Quote:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.0.1:80
<VirtualHost 192.168.0.1:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>
NameVirtualHost 192.168.0.7:80
<VirtualHost 192.168.0.7:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>
#
#
######################################
# Vhost: www.banzaiwebhosting.com:80
######################################
#
#
<VirtualHost 192.168.0.7:80>
ServerName www.banzaiwebhosting.com:80
ServerAdmin
DocumentRoot /var/www/web3/web
ServerAlias www.banzaiwebhosting.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi in$
Alias /cgi-bin/ /var/www/web3/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web3/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_flag safe_mode Off
<IfModule mod_ruby.c>
<Directory /var/www/web3/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>
<IfModule mod_python.c>
<Directory /var/www/web3/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Alias /error/ "/var/www/web3/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>
#
#
#
my ls -la /root/ispconfig/ :
Quote:
total 104
drwxr-xr-x 10 root root 4096 2008-11-15 02:20 .
drwxr-xr-x 3 root root 4096 2008-11-14 13:28 ..
-rwxr-xr-x 1 root root 35990 2008-11-06 23:40 cronolog
-rwxr-xr-x 1 root root 9673 2008-11-06 23:40 cronosplit
drwxr-xr-x 12 root root 4096 2008-11-06 23:32 httpd
drwxr-xr-x 16 root root 4096 2008-11-06 23:40 isp
drwxr-xr-x 7 root root 4096 2008-11-06 23:32 libmcrypt
-rw-r--r-- 1 root root 8 2008-11-15 02:20 .old_path_httpd_root
drwxr-xr-x 6 root root 4096 2008-11-06 23:28 openssl
drwxr-xr-x 6 root root 4096 2008-11-06 23:36 php
drwxr-xr-x 4 root root 4096 2008-11-06 23:40 scripts
drwxr-xr-x 4 root root 4096 2008-11-06 23:40 standard_cgis
drwxr-xr-x 2 root root 4096 2008-11-06 23:40 sv
-rwx------ 1 root root 9389 2008-11-06 23:40 uninstall
my tail /home/admispconfig/ispconfig/ispconfig.log:
Quote:
15.11.2008 - 02:20:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2601: . /etc/apache2/envvars && httpd -t &> /dev/null
15.11.2008 - 02:20:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2611: httpd syntax ok
15.11.2008 - 02:20:11 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 reload &> /dev/null
15.11.2008 - 02:20:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2067: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
15.11.2008 - 02:20:13 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/proftpd restart &> /dev/null
15.11.2008 - 02:43:48 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 restart &> /dev/null
15.11.2008 - 02:43:48 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
15.11.2008 - 02:43:48 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
15.11.2008 - 02:43:50 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/bind9 restart &> /dev/null
15.11.2008 - 02:43:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/proftpd restart &> /dev/null
my httpd -t:
Quote:
httpd: bad user name ${APACHE_RUN_USER}



Any help?

Last edited by banzaiwebstudio.com; 15th November 2008 at 15:49.
Reply With Quote
Sponsored Links