View Single Post
  #1  
Old 6th November 2008, 10:19
Paladinemishakal Paladinemishakal is offline
Junior Member
 
Join Date: Jan 2008
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Default HAProxy Installation problem

Hi,

I am installing HAProxy on Debian Etch and got this error when trying to get the packages from Lenny.

----------------------------------------------------------------------
sudo apt-get update
Get:1 http://ftp2.de.debian.org etch Release.gpg [386B]
Get:2 http://ftp2.de.debian.org lenny Release.gpg [189B]
Get:3 http://security.debian.org etch/updates Release.gpg [189B]
Get:4 http://ftp2.de.debian.org etch Release [58.2kB]
Hit http://security.debian.org etch/updates Release
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Hit http://ftp2.de.debian.org lenny Release
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/contrib Packages
Hit http://security.debian.org etch/updates/main Sources
Get:5 http://ftp2.de.debian.org etch/main Packages [4284kB]
Hit http://security.debian.org etch/updates/contrib Sources
Get:6 http://ftp2.de.debian.org etch/main Sources [1218kB]
Hit http://ftp2.de.debian.org lenny/main Packages/DiffIndex
Fetched 5561kB in 32s (169kB/s)
Reading package lists... Error!
E: Dynamic MMap ran out of room
E: Error occurred while processing wackamole (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp2.de.debian.org_debian_dists_lenny_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
----------------------------------------------------------------------

This is my apt sources.list
------------------------------------------------------------
deb http://ftp2.de.debian.org/debian/ etch main
deb-src http://ftp2.de.debian.org/debian/ etch main

deb http://ftp2.de.debian.org/debian/ lenny main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
-------------------------------------------------------------

This is my apt preferences
----------------------------
Package: *
Pin: release a=etch
Pin-Priority: 700

Package: *
Pin: release a=lenny
Pin-Priority: 650
----------------------------

Can I still proceed with the HAProxy installation according to the instruction? What is the problem with the error?

Regards.
Reply With Quote
Sponsored Links