View Single Post
  #5  
Old 4th November 2008, 14:57
skeldof skeldof is offline
Junior Member
 
Join Date: Oct 2008
Posts: 11
Thanks: 1
Thanked 2 Times in 2 Posts
Lightbulb

I finally got the delivery working correctly. The key problem was .mailfilter file I hadn't spotted in /home/vmail/.

To anyone else (daft enough) wishing to move the Maildir folders:
If you haven't installed yet:
  • Edit $ISPCONFIG/install/dist/conf/$YOURDISTRO.conf.php. Change $conf['postfix']['vmail_mailbox_base'] = '/home/vmail'; to point to where your mail will go.
  • Install ISPConfig3.
  • Edit the server's config to use the new mail path: System -> Server config -> $SERVER -> Mail. Update "Maildir Path" and "Homedir Path". (if till hasn't removed the option yet )

If you have installed ISPConfig it's all a little messier:
  • I highly recommend not doing this if you have any mail users active in ISPConfig. Otherwise it'll involve lots of manual SQL updating in the mail_user table.
  • Move (or copy with "cp -a") /home/vmail to the new location.
  • Update /etc/passwd and change vmail's home to the new location.
  • Edit /etc/postfix/main.cf and change "virtual_mailbox_base" option to new location.
  • Edit newlocation/.mailfilter file. Change any reference of /home/vmail to the new location.
  • Edit the server's config to use the new mail path: System -> Server config -> $SERVER -> Mail. Update "Maildir Path" and "Homedir Path". (if till hasn't removed the option yet )
  • Update any current virtual mail users if you're crazy enough to ignore the warning
  • Restart postfix
Reply With Quote