View Single Post
  #1  
Old 1st November 2008, 22:50
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 264
Thanked 151 Times in 131 Posts
Default Need to compile with G++ 3.X.

Hi all,

I need to compile something with g++ 3.X. (and not the last g++ 4.X.)
For testing I created a virtual host, with a clean install of Dbian Etch.
I installed g++ 3.x with "apt-get install g++-3.4", and it looks like this worked fine.
However when I do a ./configure I get the following error:
Quote:
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
So.. It looks like I'm missing gcc.
apt-get install gcc-3.4 looks fine, and it installs fine.

Again when I do a ./configure I get the same error as above.
The onlyway I get even close to installing is when I do an "apt-get install build-essential". but this will install ++ 4.X, and will break the make.

Any suggestion on what I could try to get this installed?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Sponsored Links