View Single Post
  #24  
Old 29th October 2008, 13:52
dayjahone dayjahone is offline
Senior Member
 
Join Date: Jan 2007
Posts: 417
Thanks: 31
Thanked 0 Times in 0 Posts
Default

When I placed it under
Code:
// Login into 42go Server
$session_id = $nusoap_client->call('login',$parameters);
I got the following:
Code:
Request

POST /remote/index.php HTTP/1.0
Host: server1.mydomain.com:81
User-Agent: NuSOAP/0.7.3 (1.51)
Content-Type: text/xml; charset=ISO-8859-1
SOAPAction: ""
Content-Length: 538

<?xml version="1.0" encoding="ISO-8859-1"?><SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns3263:login xmlns:ns3263="http://tempuri.org"><user xsi:type="xsd:string">roach</user><pass xsi:type="xsd:string">two</pass></ns3263:login></SOAP-ENV:Body></SOAP-ENV:Envelope>
Response

HTTP/1.1 200 OK
Date: Wed, 29 Oct 2008 12:48:41 GMT
Server: Apache
X-Powered-By: PHP/5.2.6
Set-Cookie: PHPSESSID=607fd47af0588e1e48411ca5fd901b00; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Transfer-Encoding: chunked
Content-Type: text/html

<br />
<b>Fatal error</b>:  Class 'soap_server' not found in <b>/home/admispconfig/ispconfig/web/remote/index.php</b> on line <b>10</b><br />
Error: Response not of type text/xml: text/html
I was asking about which brand of Linux because I've done this twice, neither time doing anything custom and neither time deviating from the perfect setup for ubuntu, and both times, it hasn't worked too well. The first time took a lot of posts and tinkering to get it to work. I was wondering if it was smoother with other brands. I picked ubuntu because I thought it was most common.
Reply With Quote