View Single Post
  #1  
Old 27th October 2008, 21:46
mikeljason mikeljason is offline
Junior Member
 
Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Question Active FTP not working with pure-ftpd

This is my first post. I have searched through all other threads looking for an answer, so I am hopeful that one of you may have a solution.

I am running Fedora 9 64bit, fresh install. I have vino/vnc running for ease of administration along with SSH. I have pure-ftpd configured and running (using the command line options: pure-ftpd -4AbBEGKHirZl puredb:/etc/pureftpd.pdb -p 50000:50100 &).

My issue is this: I can connect to this server with FTP from my windows PC with CORE FTP using PASV, but I can not connect to it using ACTIVE. When I connect from command line, I get the following: (I have replaced IP replaced with XX.XX.XX.XXX)
220---------- Welcome to Pure-FTPd ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 03:03. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
User (XX.XX.XX.XXXnone)): ftptestuser
331 User ftptestuser OK. Password required
Password:
230-User ftptestuser has group access to: 501
230 OK. Current directory is /
ftp>
ftp>
ftp> ls
500 I won't open a connection to 0.0.0.0 (only to XX.XX.XX.XXX)
425 No data connection
ftp>

I have ports 1-5000 tcp and udp open. I can FTP in to the service from the Fedora box console and connect in ACTIVE mode. What makes it even stranger is that if I shut down pure-ftpd and run vsftp I am able to connect from the Windows box using active, so it is not a firewall/network issue. I really need some of the features of pure-ftpd for the application I am using. Any suggestions would be very welcome.

One note too. It took me a good deal of time to figure out why I couldn't connect in the first place. It seems that when you disable the firewall in Fedora 9 64bit, it clamps down on FTP.
Reply With Quote
Sponsored Links