View Single Post
  #1  
Old 29th September 2008, 16:22
EazySnatch EazySnatch is offline
Junior Member
 
Join Date: Sep 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Haproxy + Lighttpd / fast cgi

Hello ,

System: Gentoo Base System release 1.12.11.1
Haproxy : HA-Proxy version 1.3.14.1
LIghttpd : lighttpd-1.4.19
PHP : spawn-fcgi-1.4.19

PHP 5.2.6-pl6-gentoo (cli) (built: Sep 10 2008 10:37:25)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
with eAccelerator v0.9.5.3, Copyright (c) 2004-2006 eAccelerator, by eAccelerator

I have this topology

Haproxy ---> apache2 servers + php / eaccelerator / memcache

I want to go on Lighttpd

I install it but haproxy send X-Forward-For I make it work with lighttpd module "mod_extforward"

Then put extforward.forwarder trusting

/ extforward.forwarder = (
"x.x.x.x" => "trust",
"x.x.x.x" => "trust"
)

This is my fast cgi module config
fastcgi.server = ( ".php" =>
( "localhost" =>
(
"socket" => "/tmp/php-fastcgi.socket",
"bin-path" => "/usr/bin/php-cgi -v /etc/php/cgi-php5/php.ini",
"min-procs" => 3,
"max-procs" => 8,
"max-load-per-proc" => 4,
"idle-timeout" => 20,
"bin-environment" => (
"PHP_FCGI_CHILDREN" => "32",
"PHP_FCGI_MAX_REQUESTS" => "1000",
),
"broken-scriptfilename" => "enable"
)
)

But I get this errors

2008-09-29 17:17:45: (mod_fastcgi.c.2471) unexpected end-of-file (perhaps the fastcgi process died): pid: 32089 socket: unix:/tmp/php-fastcgi.socket-7
2008-09-29 17:17:45: (mod_fastcgi.c.3281) response not received, request sent: 1489 on socket: unix:/tmp/php-fastcgi.socket-7 for /index.php , closing connection

2008-09-29 17:18:00: (mod_fastcgi.c.2471) unexpected end-of-file (perhaps the fastcgi process died): pid: 32056 socket: unix:/tmp/php-fastcgi.socket-6
2008-09-29 17:18:00: (mod_fastcgi.c.3281) response not received, request sent: 1419 on socket: unix:/tmp/php-fastcgi.socket-6 for /index.php , closing connection
Reply With Quote
Sponsored Links