View Single Post
  #1  
Old 18th September 2008, 09:45
almeister9 almeister9 is offline
Member
 
Join Date: Sep 2008
Posts: 36
Thanks: 6
Thanked 3 Times in 3 Posts
Unhappy phpmyadmin problem on ubuntu mail server virtual domains

Hi all.
I have almost completed the tutorial "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04 LTS)" with some very small variations, namely the "postfix quota patch" wouldnt work when I followed the instructions, so i just continued and the "dcc" for spam assassin didnt work because it is for i386 and I am on amd64, so I just continued. Everything seems to be working as the tutorial says at this point, all tests show what the tutorial says they should.
I did however notice that halfway through, the tutorial says
Quote:
BTW, (I'm assuming that the IP address of your mail server system is 192.168.0.100) you can access phpMyAdmin over http://192.168.0.100/phpmyadmin/ in a browser and log in as mail_admin. Then you can have a look at the database. Later on you can use phpMyAdmin to administrate your mail server.
page1

when I went to a different machine on my network, opened a browser and typed in the required URL http://10.1.1.55/phpmyadmin/
I received a 404 error message from my apache server on ubuntu saying that the directory does not exist.

I continued on and everything seemed to be going OK.
now I am near the end and I need to add users to the database but when I try from the terminal using mysql and the instructions in the tutorial (followed very carefully) I get syntax errors concerning ' in line 1.
I tried a few variations (dropping all ' characters) but still syntax error or similar.
If I could do it through phpmyadmin it wouldnt matter but as mentioned. phpmyadmin is not working.

I tried apt-get install phpmyadmin but it says I already have the latest version. I tried apt-get remove phpmyadmin, then apt-get install phpmyadmin and the same is happening. I have rebooted the server, to no avail.

on page 1 of the tutorial it says to setup the server (fresh install) using pages 1-3 of "perfect server ubuntu" tutorial, which I followed to a T.

I have read in another post here that in this tutorial you globally disable php so that you can enable it using ISPconfig. could this be the cause of my problem and if so, what steps could I take to rectify this.

does it have anything to do with the
Quote:
ln -sf /bin/bash /bin/sh
I should state that I am an absolute newb to linux of any flavour, I even had to look up some help to learn how to use vi.

Any help at all would be greatly appreciated.

Thanx in advance.
Reply With Quote
Sponsored Links