View Single Post
  #6  
Old 7th February 2006, 11:15
st2xo st2xo is offline
Member
 
Join Date: Jan 2006
Location: Wiesloch [DE]
Posts: 47
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
$apache_user contains the Apache user - in your case wwwrun, so there's no need to change this.
mhmh, then its even more strange on my system - the web-directories in /home/www are owned by the user with administrator-Checkbox in User&Email-Settings.

Directories created by ISPconfig without any changes from me (I didīnt patched the config.lib.php file) are like this:
Code:
drwxr-xr-x  10 web18_stefan    web18 4.0K Feb  3 15:17 web18/
drwxr-xr-x  10 web18_stefan    web18 4.0K Feb  3 15:17 www.XYZ.de/
If I deselect the admin-Checkbox the file owner changes immediately to
Code:
drwxr-xr-x  10 root            web18 4.0K Feb  7 09:51 web18/
drwxr-xr-x  10 root            web18 4.0K Feb  7 09:51 www.XYZ.de/
If now selected another user as admin the file owner changes again
Code:
drwxr-xr-x  10 web18_test2     web18 4.0K Feb  7 09:55 web18/
drwxr-xr-x  10 web18_test2     web18 4.0K Feb  7 09:55 www.XYZ.de/
So thereīs is no wwwrun user set and without set any admin-checkox root is owner of the dirs (but that seems to be correct?!)
Setting wwwrun as as the owner of alle files by ISPConfig-default would be solve all my problems How can I make that? Or whats going wrong there?
(the perfect setup was installed fine on a brandnew suse10-OS, all default, no errors, no strange things)

Quote:
Originally Posted by falko
You should assign another UID (below 10000) to your manually created user.
thanks! Thatīs it. I changed the uid manually in /etc/passwd. After exiting vi the owner from this one directory was already fixed. Now I remember that somewhere I read this thing with the uid upper than 10000
__________________
regards,
Stefan.
Reply With Quote