View Single Post
  #5  
Old 12th September 2008, 20:33
omry omry is offline
Junior Member
 
Join Date: Sep 2008
Posts: 23
Thanks: 3
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by till View Post
No, thats not a bug. You will have to create the user and directory manually before, there is no assistence from ispconfig in ths. Also it is not recommended to change this setting at and it may cause the complete vhost to fail.
I see.
from the usability standpoint, ispconfig should fail the action if the directory/user does not exist instead of succeeding with the default value.

Quote:
Originally Posted by till View Post
There is no known bug with that. I just tested it and it works for me. maybe a bug in your setup. Aditionally, if you changed the settings that you mentioned above, the creation of shell users may fail.

Create a shell user in ispconfig interface.
I deleted my test host, created it again, and now I managed to create an shell user and login with it.
one thing is bothering me:

when I create a shell user, I am associating it with a site and not with a client.
this means that for a client with multiple sites, I will have to create a user for each site. this is cumbersome.
is it possible to create a shell user for a client, which will have access to all the client sites?

About suphp:
I got it to work, but I also had to apply the patch from here:
http://www.howtoforge.com/apache2_suphp_php4_php5_p2

any idea what suphp is not patched with this by default?
looks like suphp is almost but not quite working, and it's a pity that users have to go through all those fire hoops to get it to work.
unless there is a good reason, the suphp debian package should be configured in a way that allows the use case for ispconfig by default.

thanks for all your help.
Reply With Quote