View Single Post
  #8  
Old 9th September 2008, 00:42
adobe adobe is offline
Member
 
Join Date: Sep 2008
Posts: 39
Thanks: 0
Thanked 1 Time in 1 Post
Default

Okay, I have fixed the problem by turning off quota after getting confirmation from my host that turning off quota will not hurt. This is how I fixed it:

First I worked out where is what mounted by ...

# mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw,usrquota,grpquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

Then I turned off quota like this ...

# quotaoff /dev/mapper/VolGroup00-LogVol00

And when I created a VPS, it worked without any errors like before ...

# vzctl create 109 --ostemplate debian-4.0-i386-minimal --config vps.basic
Creating VE private area (debian-4.0-i386-minimal)
Performing postcreate actions
VE private area was created

And finally, VPS Quota is working, check this out ...

[root@server ~]# vzctl set 109 --diskspace 100G:100G --save
Saved parameters for VE 109
[root@server ~]# vzctl enter 109
entered into VE 109
vps1:/# cd $HOME
vps1:~# df -h
Filesystem Size Used Avail Use% Mounted on
simfs 100G 151M 100G 1% /
tmpfs 3.9G 0 3.9G 0% /lib/init/rw
tmpfs 3.9G 0 3.9G 0% /dev/shm
earthbound-ro:~#

Posting the solution here to help anyone else who runs into similar trouble as I did.
Reply With Quote