View Single Post
  #13  
Old 6th February 2006, 02:55
joek9k joek9k is offline
Junior Member
 
Join Date: Feb 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default making software RAID work in Linux

I managed to trick Fedora Core 4 into using my Silicon Image (SIL) SATA controller for RAID 1 (mirroring) by first configuring the software RAID 1 in SuSE 10 on fresh install
md0 mounted /
md1 mounted /home
md2 mounted /swap

The funny part is the whole reason why I then took these partitions into Fedora Core 4 was because after doing the install with SuSE 10 and formatting the drives, installing everything, SuSE 10 kernel panicked upon first reboot.

So I put Fedora core 4 in there, DiskDruid picked up the partition info and then I installed it and it gave me a warning message that you'd have to see to believe but after Fedora installed I could definately hear the drives working as a Software RAID (the sound of the configuration is a dead give-away, it's like an echo, same as a recent XP pro install I did) . So it worked, but it didn't work in my O/S of choice (SuSE 10)

Another thing is I had to go and purchase the Silicon Image controller (PCI) for 40 bux (a software raid controller) which makes me want to take back my SATA drives and just get a couple IDE drives and do a software IDE raid and save all the effort.

Now that I see how much BS the software raid is I'm thinking that a 3ware hardware raid controller with true Linux support and a Server motherboard with PCI 64bit is probably worth the money because my time is worth a lot more than all this BS. Anyone selling a server motherboard for cheap?

It'd be nice if all this bios raid software raid worked right now and saw one drive instead of two. I've been searching for other distros but I think it'd be cheaper to just get a real server instead of trying to turn a $50 dollar motherboard into a real server. Maybe in Kernel 2.7.
Reply With Quote