View Single Post
  #6  
Old 18th August 2008, 15:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by ChrisX View Post
Nevermind

vi /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf

Find the server, edit the AllowOverride statement. Works like a charm.

Why did I need to do it there? I checked "Python" in the ispconfig page for this site.

Even if you edit this, the next time you save the page in ISPConfig, it will put it back, no matter what is in "Apache Directives".

Once I unchecked "Python", and added this to Apache Directives....

<IfModule mod_python.c>
<Directory /var/www/web3/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride all
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

Everything works now. Python, and AllowOverride.

Unless I missed something, this is a bug.
I've now replaced
Code:
AllowOverride None
with
Code:
AllowOverride Indexes AuthConfig Limit FileInfo
in SVN.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote