View Single Post
  #3  
Old 9th August 2008, 04:22
sebastienp sebastienp is offline
Junior Member
 
Join Date: Mar 2008
Posts: 16
Thanks: 5
Thanked 0 Times in 0 Posts
Default to be continued

Hi Thanis, first of all many thanks for your answer, maybe you're on vacations... Nice from you to take the time.

OK, I worked a lot since last post, and ' got it, for sure, heartbeat and drbd are "by themselves". Commited.

I now use vmware server 1.0.6 instead of 1.0.5, just in case...
But same shit...
Downgrading to 1.0.2, why not, it's my last chance !?

Nevertheless, the mes is with ethernet card (these are HP servers, according to HP full compatible with debian etch. I don't know for vmware).

No problem with the primary server (srv1). My vms bind AMD pcnet card as eth0 with its IP staticaly configured.

But when moving to srv2, I always have the same error:
SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device (twice)
Bind socket to interface: No such device
Failed to bring up eth0
...at boot sequence, and no eth0 available.

ifconfig -a shows that eth0 doesn't exists, but eth1 is there ! (It's not there on srv1...).

I read several things about /etc/udev/rules.d/z25_persistent-net.rules.
I tried to remove/tune it, successless.

I want to use several (2-4) Linux vms and only 1 Windows 2003 server vm (specific purpose/service). How many did you try in your lab ? Which OS ?

FYI, the problem is there with only Linux vms, and also with only the Windows vm. Gods love us ;-)

Once again, no problem on srv1.
But as soon as I disconnect it, srv2 holds back vmware instance, OK, but it's just like eth0 vanished !

That was my first try, I used a bridged network configuration (what kind of vmware network configuration did you use for your test lab ?).

Now, I'm trying with a NAT config, I have a couple of possibilities.
- tuning nat.conf for vmnet8 on both servers, so that they share the same "NATed network". What about MAC addresses ? They are the same for vmnet8. To be tested;
- using a tunnel broker solution, but I'm not familiar to IPv6. To be tested;

I'm still working on it...

I can say I never saw something explicit in the log files, except the NIC failure... It's the main problem !

Sorry to ask, but could you please send a basic sketch of your topology when you did it ?
I find your howto very interesting and knwoledgefull, but if you permit, not so detailled considering the topic, even for linux/vmware users.

That's easy to say for me cause I never posted an howto, but I promise, if I succeed in doing this one, I sware I'll post something !

I'll keep you updated, once again many thanks for your time.

Regards,
S.
Reply With Quote