View Single Post
  #2  
Old 8th August 2008, 06:38
ChrisX ChrisX is offline
Junior Member
 
Join Date: Jul 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nevermind

vi /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf

Find the server, edit the AllowOverride statement. Works like a charm.

Why did I need to do it there? I checked "Python" in the ispconfig page for this site.

Even if you edit this, the next time you save the page in ISPConfig, it will put it back, no matter what is in "Apache Directives".

Once I unchecked "Python", and added this to Apache Directives....

<IfModule mod_python.c>
<Directory /var/www/web3/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride all
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

Everything works now. Python, and AllowOverride.

Unless I missed something, this is a bug.

Last edited by ChrisX; 8th August 2008 at 07:17.
Reply With Quote