View Single Post
  #9  
Old 3rd August 2008, 11:14
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Ok more searching into this, I found out centos logs the sudo command to /var/log/secure and I have this error that seems to occur when I check statistics in ispconfig while the option to use sudo is set to 1 in config.inc.php

Aug 1 10:33:14 server1 sudo: admispconfig : sorry, you must have a tty to run sudo ; TTY=unknown ; PWD=/home/admispconfig/ispconfig/web/multidoc/edit ; USER=root ; COMMAND=/usr/bin/du -h --max-depth=1 /var/www/web2

but i'm not sure what's the best way to fix this. I've found some info that suggest this :

Quote:
...
requiretty If set, sudo will only run when the user is logged in to a
real tty. This will disallow things like "rsh somehost
sudo ls" since rsh(1) does not allocate a tty. Because it
is not possible to turn off echo when there is no tty
present, some sites may with to set this flag to prevent a
user from entering a visible password. This flag is off by
default.
...
tty_tickets If set, users must authenticate on a per-tty basis. Nor-
mally, sudo uses a directory in the ticket dir with the
same name as the user running it. With this flag enabled,
sudo will use a file named for the tty the user is logged
in on in that directory. This flag is off by default.
from the sudo man pages, and someone suggested turning those options off. Is that safe to do? Or is there any other way to fix that? Thanks
Reply With Quote