View Single Post
  #9  
Old 2nd August 2008, 20:12
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Till, I've done some looking around on sudo and it would seem even if I add admispconfig to the /etc/sudoers file according to the howto, I still need to type "sudo" to run the du command, the only difference is I don't need a password.

So instead of the

du -h --max-depth=1

command you asked me to test with, which still says permission denied. I tried the line :

sudo du -h --max-depth=1

and that worked beautifully. Is this in fact how it's supposed to work? If so is there a bug in ispconfig that's calling that command incorrectly when I turn on that option in the config.inc.php file? Should it be calling it via "sudo du -h --max-depth=1" instead of just "du -h --max-depth=1" ?

Maybe this is just for Centos as well? But it would seem my /etc/sudoers file does work as the NOPASSWD option certainly is working.

Quote:
Originally Posted by till View Post
To find out why the procedure does not work on your system:

1) add the admispconfig settings for sudo.
2) run:

su admispconfig

to become ispconfig user, so you get the same resiults as the controlpanel. Then change to a web directory:

cd /var/www/www.domain.com

and execute the command:

du -h --max-depth=1

and check if the output is correct or if you get any error messages. ISPConfig is just displaying the output of this cammend in the interface.

Last edited by tal56; 2nd August 2008 at 20:22.
Reply With Quote