View Single Post
Old 1st February 2006, 23:38
senzapaura senzapaura is offline
Junior Member
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts

Till, Thanks for the help.

I have double checked my DNS record for my external domain name ( and made sure the external IP address and its A-Record is pointing to my router. This is a dumb router and it relays the messages to a Linux firewall running Astaro. I then checked my firewall to make sure it is sending all messages from that external IP address to the correct internal IP address of the web server that contains a Named Virtual Host for the external domain name. This includes HTTP and HTTPS services. Please remember this site is accessible externally using The web server’s internal name is amgsrv1 and the internal domain it is running on is I also double checked these settings. It is my understanding that the firewall uses the internal server name tied to the internal IP address to reroute the message. It is possible that this is a problem, is anyone else you know using Astaro? I have also double checked the virtual host file it appears to be correct. I obviously have an error someplace, but if my assumptions are correct I have exhausted my options for debugging this problem. It was originally generated (virtual host file)using ISPConfig. To expedite my testing I have made some manual changes to the file figuring when I get it working I can regenerate it with ISPConfig. I just do not know how to confirm these settings any further unless I had the ability to look inside the messages and confirm they are being sent properly. Would you agree that the problem appears not to be in the SSL certificate? Could you show me what an ISPConfig virtual host file should look like to make sure it is configured for a named domain? I think you are correct, but how do I make it use the domain name?

Last edited by senzapaura; 2nd February 2006 at 18:27.
Reply With Quote
Sponsored Links