View Single Post
  #3  
Old 3rd July 2008, 11:25
onik onik is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

However I have found some problem as under:
------------------------------------------
#postconf -a
dovecot
cyrus

I have installed dovecot imap server. But....

[root@] # dovecot -n | head -1
Error: Error in configuration file /usr/local/etc/dovecot.conf line 1: Expecting '='
Fatal: Invalid configuration in /usr/local/etc/dovecot.conf

/usr/local/etc/dovecot.conf is as under:
-------------------------------------------------------------------
# Basic Configuration
base_dir = /var/run/dovecot/
protocols = imap pop3
listen = *
disable_plaintext_auth = no
# Logging
log_path = /var/log/dovecot.log
info_log_path = /var/log/dovecot-info.log
# SSL
ssl_disable = yes
ssl_listen =
# Login Processes
login_dir = /var/run/dovecot/login
login_chroot = yes
login_process_size = 64
login_process_per_connection = yes
login_processes_count = 3
login_max_processes_count = 128
login_max_connections = 256
login_greeting = Dovecot ready
# Mailbox locations
mail_location = mbox:~/mail:INBOX=/var/mail/%u
# mail_location = maildir:~/Maildir
# mbox (Traditional)
mbox_read_locks = fcntl
mbox_write_locks = fcntl
# maildir (Latest)

# Mail Processes
max_mail_processes = 1024
mail_process_size = 256
mail_max_keyword_length = 50
# IMAP Specific Settings
protocol imap {
login_executable = /usr/libexec/dovecot/imap-login
mail_executable = /usr/libexec/dovecot/imap
mail_plugins =
mail_plugin_dir = /usr/lib/dovecot/imap
}
# POP3 specific settings
protocol pop3 {
login_executable = /usr/libexec/dovecot/pop3-login
mail_executable = /usr/libexec/dovecot/pop3
mail_executable = /usr/libexec/dovecot/pop3
}
# Authentication processes
auth_executable = /usr/libexec/dovecot/dovecot-auth
auth_process_size = 256
auth_realms =
auth_username_chars = abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWX YZ01234567890.-_@
auth default {
mechanisms = plain login
passdb pam {
}
userdb passwd {
}
socket listen {
client {
# Assuming the default Postfix $queue_directory setting
path = /var/spool/postfix/private/auth
mode = 0660
# Assuming the default Postfix user and group
user = postfix
group = postfix
}
}
}

-----------
Reply With Quote