View Single Post
  #1  
Old 25th June 2008, 06:37
yuro yuro is offline
Junior Member
 
Join Date: Jun 2008
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default httpd and ssl issues.

When I try and run "apache2ctl restart" I get the error
Code:
httpd not running, trying to start
here's the output of error_log from the httpd folder:
Code:
[Tue Jun 24 21:41:13 2008] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
[Tue Jun 24 21:41:13 2008] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
[Tue Jun 24 21:41:13 2008] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
[Tue Jun 24 21:41:13 2008] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
[Tue Jun 24 21:41:16 2008] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
[Tue Jun 24 21:41:16 2008] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
du: cannot read directory `/var/www/web3/.subversion/auth': Permission denied
du: cannot read directory `/var/www/web3/user/magento/Maildir': Permission denied
du: cannot read directory `/var/www/web3/user/magento/.spamassassin': Permission denied
du: cannot read directory `/var/www/web3/.subversion/auth': Permission denied
du: cannot read directory `/var/www/web3/user/magento/Maildir': Permission denied
du: cannot read directory `/var/www/web3/user/magento/.spamassassin': Permission denied
[Wed Jun 25 00:35:14 2008] [notice] caught SIGTERM, shutting down
[Wed Jun 25 00:36:39 2008] [notice] Apache configured -- resuming normal operations
[Wed Jun 25 00:36:39 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Jun 25 00:37:38 2008] [notice] caught SIGTERM, shutting down
[Wed Jun 25 00:37:45 2008] [notice] Apache configured -- resuming normal operations
[Wed Jun 25 00:37:45 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Jun 25 00:46:51 2008] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
[Wed Jun 25 00:46:51 2008] [error] System: Connection reset by peer (errno: 104)
[Wed Jun 25 00:53:01 2008] [notice] caught SIGTERM, shutting down
[Wed Jun 25 00:54:18 2008] [notice] Apache configured -- resuming normal operations
[Wed Jun 25 00:54:18 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Jun 25 01:36:24 2008] [notice] caught SIGTERM, shutting down
[Wed Jun 25 01:37:47 2008] [notice] Apache configured -- resuming normal operations
[Wed Jun 25 01:37:47 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Jun 25 09:07:19 2008] [notice] caught SIGTERM, shutting down
[Wed Jun 25 09:08:40 2008] [notice] Apache configured -- resuming normal operations
[Wed Jun 25 09:08:40 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Jun 25 09:12:00 2008] [notice] caught SIGTERM, shutting down
Output of httpd -t
Code:
Syntax OK
output of netstat -tap
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN      4322/mysqld     
tcp        0      0 75-149-58-xxx-SF:domain *:*                     LISTEN      4932/named      
tcp        0      0 75-149-58-xxx-SF:domain *:*                     LISTEN      4932/named      
tcp        0      0 75-149-58-xxx-SF:domain *:*                     LISTEN      4932/named      
tcp        0      0 75-149-58-xxx-SF:domain *:*                     LISTEN      4932/named      
tcp        0      0 web1.xxxxxxxxxx.co:domain *:*                     LISTEN      4932/named      
tcp        0      0 localhost.locald:domain *:*                     LISTEN      4932/named      
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      4932/named      
tcp        0      0 *:smtp                  *:*                     LISTEN      4885/master     
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      4443/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      4482/couriertcpd
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      4462/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      4423/couriertcpd
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      4961/proftpd: (acce
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      4224/sshd       
tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN      4932/named      
tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      4885/master     
tcp6       0    720 web1.xxxxxxxxx.com:ssh   192.168.2.134%819:56934 ESTABLISHED 5016/0
output of df -h
Code:
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1              36G  2.1G   32G   7% /
varrun                248M   92K  248M   1% /var/run
varlock               248M     0  248M   0% /var/lock
udev                  248M   32K  248M   1% /dev
devshm                248M     0  248M   0% /dev/shm
Now if I "a2dismod ssl" I don't have any problems, but I still don't have ssl!
Code:
root@web1:~/ispconfig/httpd/logs# a2dismod ssl
Module ssl disabled; run /etc/init.d/apache2 force-reload to fully disable.
root@web1:~/ispconfig/httpd/logs# /etc/init.d/apache2 force-reload
 * Reloading web server config apache2
root@web1:~/ispconfig/httpd/logs# apache2ctl restart
httpd not running, trying to start
root@web1:~/ispconfig/httpd/logs# apache2ctl start
httpd (pid 5342) already running
root@web1:~/ispconfig/httpd/logs# apache2ctl restart
root@web1:~/ispconfig/httpd/logs# /etc/init.d/apache2 force-reload
 * Reloading web server config apache2
   ...done.
root@web1:~/ispconfig/httpd/logs# a2enmod ssl
Module ssl installed; run /etc/init.d/apache2 force-reload to enable.
root@web1:~/ispconfig/httpd/logs# /etc/init.d/apache2 force-reload
 * Reloading web server config apache2
   ...done.
root@web1:~/ispconfig/httpd/logs# apache2ctl start
root@web1:~/ispconfig/httpd/logs# apache2ctl restart
httpd not running, trying to start

Last edited by yuro; 25th June 2008 at 18:46.
Reply With Quote
Sponsored Links