View Single Post
  #1  
Old 26th January 2006, 16:59
Median Median is offline
Member
 
Join Date: Jan 2006
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect Setup - Fedora Core 3 - saslauthd problem

Hi.

I read in one of Falko's posts somewhere that the Perfect Setup Fedora Core 3 is basically the same for Fedora Core 2. I have followed that and have got so far, but now I have encountered my first error.

Quote:
Now start Postfix, saslauthd, imap and pop3:

chkconfig --levels 235 sendmail off
chkconfig --levels 235 postfix on
chkconfig --levels 235 saslauthd on
works fine.
We then come to
Quote:
chkconfig imap on
and I get an error,
Code:
error reading information on service imap: No such file or directory
which is fine as Dovecot was installed instead of imap, so I change this to
Code:
chkconfig Dovecot on
and it seems to be ok.
Quote:
chkconfig imaps on
chkconfig ipop3 on
chkconfig pop3s on
all produce the same error.

>>>>> Should I replace these lines with anything or just leave them out?

Quote:
/etc/init.d/sendmail stop
/etc/init.d/postfix start
/etc/init.d/saslauthd start
/etc/init.d/xinetd restart
All seem to work ok apart from
Quote:
/etc/init.d/saslauthd start
which throws an error saying
Code:
could not read from startup_pipe
If I just type
Code:
saslauthd start
at the prompt I get an error telling me
Code:
no authentication method specified
and list of options which seems to suggest that saslauthd is there somewhere ready to go but I'm just not giving it the right information. I tried
Code:
saslauthd -a pam
which throws up the message:
Code:
saslauthd[22578] :detach_tty      : Cannot start saslauthd
saslauthd[22578] :detach_tty      : could not read from startup_pipe
Obviously I'm missing something here. Would be grateful if someone could help me out.

Thanks in advance
Reply With Quote
Sponsored Links