View Single Post
  #3  
Old 14th June 2008, 22:23
Tipem Tipem is offline
Junior Member
 
Join Date: Jun 2008
Posts: 14
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Thanks... the installation and stuff worked and Lighttpd came up right after the first yum installation. I continued on with the tutorial to get Lighttpd working and I modified lighttpd.conf to enable fastcgi. I then restarted via /etc/init.d/lighttpd restart and now when I run /etc/init.d/lighttpd status it says lighttpd dead but pid file exists. How can I fix this to get Lighttpd working again? It worked right after the install but after enabling FastCGI, it's "dead." Any ideas?

Thanks for your help! Awesome site!

EDIT 1: Here's the error.log file:

Quote:
2008-06-14 16:15:13: (log.c.75) server started
2008-06-14 16:15:13: (mod_fastcgi.c.904) bind failed for: unix:/var/run/lighttpd/php-fastcgi.socket-0 No such file or directory
2008-06-14 16:15:13: (mod_fastcgi.c.1340) [ERROR]: spawning fcgi failed.
2008-06-14 16:15:13: (server.c.908) Configuration of plugins failed. Going down.
EDIT 2: I commented out the server.fastcgi() stanza in the lighttpd.conf file and rebooted. Now the server works fine. It's a problem with FastCGI, that's for sure. Any ideas?

Last edited by Tipem; 14th June 2008 at 22:54.
Reply With Quote