View Single Post
  #1  
Old 13th June 2008, 19:01
glennv glennv is offline
Junior Member
 
Join Date: Jun 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier, MySQL...Ubuntu 8.04

I've followed this tuturial step by step.. and everything has worked fine until I shall test smtp.
I try to telnet to port 25 -> connect's ..but get's disconnected afer 1 sec ..and reason according to logs is this.

Code:
warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL 
fatal: no SASL authentication mechanisms
I've googled and banged my head against the wall for 7-8 hours now .. without solving it.

To me it looks like saslauthd dont find it's login mechanism.. and acording to some other forums this is solved by adding those libs ..

But what I can se both libplain and liblogin is pressent in /usr/lib/sasl2/
wich is the ones I list (And they offcause should be there since I've installed all packs according to tuto.) in /etc/postfix/sasl/smtpd.conf



Code:
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: mail_admin
sql_passwd: mypassw
sql_database: mail
sql_select: select password from users where email = '%u'
So. how do I find out what it is that fails ..??
What coud it be that results in the above error log.??

And I'm as sure as I can be that all config-files are exactly as the tuto says.
If I've done something wrong .. what can it be??
Please help me! I'l be gratefull forever!!

Iv'e narowed it down some I think . but still not able to find the solution
I found that I could test saslauthd by running
Code:
testsaslauthd -u user -p pass  -s smtp
ressult of that is
Connect() : No such file or directory
bit if I add this
Code:
testsaslauthd -u user -p pass -f /var/spool/postfix/var/run/saslauthd/mux -s smtp
It actualy works .. it says ok if I use correct user/password from the db and tels me auth fails if I use wrong password

I have myselfe no clue why it is like this .. can I ad dthat info somewhere in the configfiles so postfix can comunicate with it or am I on the wrong track here.

Last edited by glennv; 14th June 2008 at 01:02. Reason: Done more investigateing
Reply With Quote
Sponsored Links