View Single Post
  #3  
Old 28th May 2008, 18:59
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko View Post
It seems as if SquirrelMAil is configured for Cyrus-IMAP instead of uw-imap. Please run
Code:
/usr/sbin/squirrelmail-configure
and reconfigure SquirrelMail (see http://www.howtoforge.com/virtual-us...-ubuntu8.04-p5 ).
Hi falko,


Performed following steps.


$ sudo /usr/sbin/squirrelmail-configure

2 Server Settings --> (IMAP Settings) 8. Server software : other;
(changed to ; )
uw
--> S (command >>)
Data saved in config.php
Press enter to continue... [Enter]
command >> Q [Enter]


8. Plugins
can't find change_sqlpass


$ sudo /etc/init.d/apache2 reload


On Server-1 browser run;

https://192.168.0.52/squirrelmail/

It changes to;

https://192.168.0.52/squirrelmail/src/login.php

login fails. Finally it prompts;
Code:
ERROR: Connection dropped by IMAP server.

$ tail /var/log/auth.log
Code:
May 28 22:17:01 mail CRON[7212]: (pam_unix) session opened for user root by (uid=0)
May 28 22:17:01 mail CRON[7212]: (pam_unix) session closed for user root
May 28 22:39:01 mail CRON[7228]: (pam_unix) session opened for user root by (uid=0)
May 28 22:39:01 mail CRON[7228]: (pam_unix) session closed for user root
May 28 23:09:01 mail CRON[7417]: (pam_unix) session opened for user root by (uid=0)
May 28 23:09:01 mail CRON[7417]: (pam_unix) session closed for user root
May 28 23:17:01 mail CRON[7430]: (pam_unix) session opened for user root by (uid=0)
May 28 23:17:01 mail CRON[7430]: (pam_unix) session closed for user root
May 28 23:39:01 mail CRON[7458]: (pam_unix) session opened for user root by (uid=0)
May 28 23:39:01 mail CRON[7458]: (pam_unix) session closed for user root

$ tail /var/log/mail.log
Code:
May 28 23:48:11 mail postfix/smtpd[7475]: connect from unknown[190.24.214.154]
May 28 23:48:12 mail postfix/smtpd[7475]: 8D014DF005D: client=unknown[190.24.214
.154]
May 28 23:48:13 mail postfix/cleanup[7480]: 8D014DF005D: message-id=<000701c8c0d
8$079f87ec$697a31b7@giqbh>
May 28 23:48:13 mail postfix/qmgr[5083]: 8D014DF005D: from=<postmaster@canalhori
zons.com>, size=1497, nrcpt=1 (queue active)
May 28 23:48:13 mail postfix/local[7481]: 8D014DF005D: to=<satimis@satimis.com>,
 relay=local, delay=0.83, delays=0.82/0.01/0/0.01, dsn=2.0.0, status=sent (deliv
ered to command: procmail -a "$EXTENSION")
May 28 23:48:13 mail postfix/qmgr[5083]: 8D014DF005D: removed
May 28 23:48:13 mail postfix/smtpd[7475]: disconnect from unknown[190.24.214.154
]
May 28 23:51:33 mail postfix/anvil[7477]: statistics: max connection rate 1/60s 
for (smtp:190.24.214.154) at May 28 23:48:11
May 28 23:51:33 mail postfix/anvil[7477]: statistics: max connection count 1 for
 (smtp:190.24.214.154) at May 28 23:48:11
May 28 23:51:33 mail postfix/anvil[7477]: statistics: max cache size 1 at May 28
 23:48:11

$ tail /var/log/mail.err
Code:
May 20 18:38:24 mail postfix[5936]: error: to submit mail, use the Postfix sendmail command
May 20 18:38:24 mail postfix[5936]: fatal: the postfix command is reserved for the superuser
May 20 18:38:25 mail postfix[5939]: error: to submit mail, use the Postfix sendmail command
May 20 18:38:25 mail postfix[5939]: fatal: the postfix command is reserved for the superuser
May 20 18:38:26 mail postfix[5942]: error: to submit mail, use the Postfix sendmail command
May 20 18:38:26 mail postfix[5942]: fatal: the postfix command is reserved for the superuser
May 20 18:38:27 mail postfix[5945]: error: to submit mail, use the Postfix sendmail command
May 20 18:38:27 mail postfix[5945]: fatal: the postfix command is reserved for the superuser
May 20 18:40:33 mail postfix[6004]: error: to submit mail, use the Postfix sendmail command
May 20 18:40:33 mail postfix[6004]: fatal: the postfix command is reserved for the superuser

https://192.168.0.52/src/configtest.php
Code:
The requested URL /src/configtest.php was not found on this server.

Edit-1:

$ sudo nano /etc/c-client.cf
copying following lines on it;
Code:
I accept the risk
set disable-plaintext 0
(also tried "nil")


$ sudo nano /etc/init.d/saslauthd
change;
PIDFILE="/var/run/${NAME}/saslauthd.pid"

as;
PIDFILE="/var/spool/postfix/var/run/${NAME}/saslauthd.pid"


$ sudo nano /etc/default/saslauthd
deleting following lines;
PWDIR="/var/spool/postfix/var/run/saslauthd"
PIDFILE="${PWDIR}/saslauthd.pid"

changing;
PARAMS="-m ${PWDIR}"

as;
PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"


& cat /etc/default/saslauthd
Code:
# This needs to be uncommented before saslauthd will be run automatically
START=yes
PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"

# You must specify the authentication mechanisms you wish to use.
# This defaults to "pam" for PAM support, but may also include
# "shadow" or "sasldb", like this:
# MECHANISMS="pam shadow"

MECHANISMS="pam"

$ sudo /etc/init.d/saslauthd restart
Code:
Stopping SASL Authentication Daemon: saslauthd.
Starting SASL Authentication Daemon: changed ownership of `/var/run/saslauthd' to root:sasl
mode of `/var/run/saslauthd' changed to 0710 (rwx--x---)
saslauthd.

$ sudo /etc/init.d/inetd restart
No printout

$ sudo /etc/init.d/apache2 reload
Code:
 * Reloading apache 2.0 configuration...             [ ok ]

On Server-1 browser run;
https://192.168.0.52/squirrelmail/src/login.php

still fail unble to login;
ERROR: Connection dropped by IMAP server.


B.R.
satimis

Last edited by satimis; 29th May 2008 at 05:15.
Reply With Quote