View Single Post
  #1  
Old 27th May 2008, 11:42
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 426
Thanks: 34
Thanked 26 Times in 21 Posts
Send a message via ICQ to radim_h
Unhappy mailuser login - how to log in with dovecot authentification

Hell-o !

I'm using loging to dovecot in my positfix main.cf
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth

then in dovecot.conf
auth_username_format ="%Ld_%Ln"

(which means that my users are logging with with their whole email adress , not using any kind of rewrite to virtusertable format.
Email adress is also set in their email clients and I also cannot use webmail packeges for ISPC as there are scripts to rewrite email adresses to system format)
and i'm getting then same error like in following...

My problem is: I cannot log into ISPConfig with mailuser login
( https://www.domain.com:81/mailuser/)
as i'm getting :
May 27 10:31:33 web1 dovecot: pop3-login: Disconnected: user=<_domain.tld_test>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured

I have no idea why the underscore in front of user name is appearing

IMHO it is caused because
/home/admispconfig/ispconfig/web/mailuser/lib/classes/pop3.inc.php

is using some kind of rewrite for email addresses user@domain.tld to system users format domain.tld_user


Does anyone has please idea hot to change
/home/admispconfig/ispconfig/web/mailuser/lib/classes/pop3.inc.php

to not rewrite email adress into _domain.tld_user ?

Format domain.tld_user can be used, but i have no idea what is causing that underscore in front of user name ..

Last edited by radim_h; 27th May 2008 at 11:45.
Reply With Quote
Sponsored Links