View Single Post
  #1  
Old 25th May 2008, 00:52
ehsan ehsan is offline
Junior Member
 
Join Date: Sep 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig update reset the whole database

I had a server running ISPConfig 2.2.17, and I decided to update it to 2.2.23 today. My MySQL root password contained an ampersand at the beginning, which caused the update to fail. Apparently the password was passed to the mysql utility on the command line, and the & at the beginning of the password just confused the installer.

I tried changing the MySQL root password temporarily and updated /home/admispconfig/ispconfig/lib/config.inc.php, and re-ran the installer.

This time the installer went ahead just fine, and I tried logging in to ISPConfig after it finished, and I observed that my admin login no longer works. I then tried "admin" as the password, and it worked. I suspected that something is fishy and looked around, and apparently, all of the ISPConfig database has been reset to the fresh state by the installer! It looks like a brand new ISPConfig installation...

This is very bad, because I won't be able to use ISPConfig to manage anything from now on, and I have to do everything manually in the config files... And stupid me, I don't have a backup from this DB on this server which I can resort to.

Is there any chance of getting the data back? All of the config files that ISPConfig had written are still in place. This server hosted only four web sites, so I still have a lot of the details in memory.

Thanks for your help, I'm desperately in need of some...

Ehsan
Reply With Quote
Sponsored Links