View Single Post
  #2  
Old 19th January 2006, 08:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by hallik
Everything went ok on the install except two parts: Setting up root password for mysql and the edit of saslauthd.

When I ran the following command:

mysqladmin -u root password mypassword

I get:

mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user: 'root@localhost' (Using password: NO)'
You seem to have set another MySQL password before. To use another password, you can try this:
Code:
mysqladmin -u root -p<current_password> password <new_password>
Note: There's no space between -p and <current_password>!


Quote:
Originally Posted by hallik
Finally, running this command I get this:

/etc/init.d/saslauthd start
/etc/init.d/saslauthd: line 54: syntax error near unexpected token `('

This is that section in my saslauthd:

Code:
# Consider our options
case "${1}" in
  start)
        echo -n "Starting ${DESC}: "
        #dir=`dpkg-statoverride --list $PWDIR`
        test -z "$dir" || createdir $dir
        if start-stop-daemon ${START} >/dev/null 2>&1 ; then
                echo "${NAME}."
        else
                if start-stop-daemon --test ${START} >/dev/null 2>&1; then
                        echo "(failed)."     <----Line 54
                        exit 1
                else
                        echo "${DAEMON} already running."
                        exit 0
                fi
        fi
        ;;
  stop)
Ideas?
thank you for any help.

<edit> I do have to say as far as the second question, the test display the exact results as the screenshot in the HOW-TO, so it may not be an issue. This is also a fresh install on a test server.
Strange... You could try to replace
Code:
echo "(failed)."
with
Code:
echo '(failed).'
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote