View Single Post
  #1  
Old 19th January 2006, 08:19
hallik hallik is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Newbie Question: ISP-Server Setup - Ubuntu 5.10 "Breezy Badger"

Everything went ok on the install except two parts: Setting up root password for mysql and the edit of saslauthd.

When I ran the following command:

mysqladmin -u root password mypassword

I get:

mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user: 'root@localhost' (Using password: NO)'

netstat -tap shows:

tcp 0 0 localhost.localdo:mysql *:* LISTEN 16824/mysqld

so it seems to be working ok. I tried different variations of creating the account I found on other websites but nothing changes/works except sometimes with different commands I get:

# mysql -u root -p
Enter password:
ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)


And I see this at the end of my syslog, so it's telling me to set it up, but it won't let me:

Jan 18 23:53:15 server mysqld_safe[16722]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
Jan 18 23:53:15 server mysqld_safe[16722]: To do so, start the server, then issue the following commands:
Jan 18 23:53:15 server mysqld_safe[16722]: /usr/bin/mysqladmin -u root password 'new-password'

Finally, running this command I get this:

/etc/init.d/saslauthd start
/etc/init.d/saslauthd: line 54: syntax error near unexpected token `('

This is that section in my saslauthd:

Code:
# Consider our options
case "${1}" in
  start)
        echo -n "Starting ${DESC}: "
        #dir=`dpkg-statoverride --list $PWDIR`
        test -z "$dir" || createdir $dir
        if start-stop-daemon ${START} >/dev/null 2>&1 ; then
                echo "${NAME}."
        else
                if start-stop-daemon --test ${START} >/dev/null 2>&1; then
                        echo "(failed)."     <----Line 54
                        exit 1
                else
                        echo "${DAEMON} already running."
                        exit 0
                fi
        fi
        ;;
  stop)
Ideas?
thank you for any help.

<edit> I do have to say as far as the second question, the test display the exact results as the screenshot in the HOW-TO, so it may not be an issue. This is also a fresh install on a test server.

Last edited by hallik; 19th January 2006 at 08:33.
Reply With Quote
Sponsored Links